Bugreport

Общие вопросы, связанные с работой сайта и форума
Аватара пользователя
alecv
Advanced Member
Сообщения: 5955
Зарегистрирован: 05.10.2004,11:13
Откуда: Санкт-Петербург
Контактная информация:

Вклад в сообщество

Bugreport

Сообщение alecv » 13.05.2019,11:48

Да, старые картинки битые.
viewtopic.php?t=12&p=234038#p234038
вложение
download/file.php?id=188

pahan
Advanced Member
Сообщения: 1327
Зарегистрирован: 13.03.2015,14:23
Откуда: Химки, М.О.

Bugreport

Сообщение pahan » 13.05.2019,17:04

Не знаю, как такое вообще могло получиться - возможно, какой-то не тот ASCII-режим при переносе вложений? Не совпадение же, что заменяются символы возврата каретки (0Dh) и перевода строки (0Ah) на просто перевод строки 0Ah (Unix-style).
Явно качали по FTP и забыли переключить ascii/binary. Неужели старый форум ещё и между разными ОС переносили? иначе вообще не понимаю, почему нельзя было включить binary принудительно для всех файлов.

Аватара пользователя
Serge
Тех.адм.
Сообщения: 2026
Зарегистрирован: 04.11.2001,19:04
Откуда: Tallinn, Estonia
Контактная информация:

Bugreport

Сообщение Serge » 14.05.2019,08:17

pahan писал(а):
13.05.2019,17:04
Явно качали по FTP и забыли переключить ascii/binary. Неужели старый форум ещё и между разными ОС переносили? иначе вообще не понимаю, почему нельзя было включить binary принудительно для всех файлов.
Напоминаю, что это тема для сообщений об ошибках, а не о домыслах о причинах возникновения ошибок.
С наилучшими,
Серж

Музей, оф.сайт

La Forge
Advanced Member
Сообщения: 3632
Зарегистрирован: 16.11.2012,17:29
Откуда: Рязань

Вклад в сообщество

Bugreport

Сообщение La Forge » 14.05.2019,16:30

не всегда получается редактировать сообщение. При отправке долго висит и пишет "сервер не вернул данных"

Аватара пользователя
uav1606
Advanced Member
Сообщения: 4652
Зарегистрирован: 16.01.2008,22:04
Откуда: Енакиево
Контактная информация:

Вклад в сообщество

Bugreport

Сообщение uav1606 » 15.05.2019,10:06

Обнаружил ещё один глюк - многие очень старые темы (2005-2006 года) не открываются, вываливая что-то вроде этого:

Код: Выделить всё

[phpBB Debug] PHP Warning: in file [ROOT]/vendor/s9e/text-formatter/src/Renderer.php on line 19: DOMDocument::loadXML(): Unescaped '<' not allowed in attributes values in Entity, line: 1
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/s9e/text-formatter/src/Renderer.php on line 19: DOMDocument::loadXML(): attributes construct error in Entity, line: 1
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/s9e/text-formatter/src/Renderer.php on line 19: DOMDocument::loadXML(): Couldn't find end of Start Tag LINK_TEXT line 1 in Entity, line: 1
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/s9e/text-formatter/src/Renderer.php on line 19: DOMDocument::loadXML(): Opening and ending tag mismatch: URL line 1 and LINK_TEXT in Entity, line: 1
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/s9e/text-formatter/src/Renderer.php on line 19: DOMDocument::loadXML(): Opening and ending tag mismatch: r line 1 and URL in Entity, line: 1
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/s9e/text-formatter/src/Renderer.php on line 19: DOMDocument::loadXML(): Extra content at the end of the document in Entity, line: 1

На этот раз дело не в подписях, а, видимо, в ссылках в каком-то сообщении темы. Если найти проблемное сообщение (как - это отдельный вопрос, хоть я и придумал один метод) и пересохранить его, то проблема исчезает.
При редактирование проблемное сообщение выглядит примерно так:

phantom2.PNG

(При пересохранении желательно ещё поправить ссылки, чтобы они не сливались с текстом - возможно, в этом и корень проблемы.)

Несколько тем я так поправил, но сколько их всего - не знаю.

Аватара пользователя
uav1606
Advanced Member
Сообщения: 4652
Зарегистрирован: 16.01.2008,22:04
Откуда: Енакиево
Контактная информация:

Вклад в сообщество

Bugreport

Сообщение uav1606 » 19.05.2019,22:39

Кстати, заметил ещё такой баг - если пересохранить первое сообщение какой-нибудь темы со старого форума, то исчезает подзаголовок в скобках. Чтобы этого не произошло, нужно всё название темы вручную скопировать в поле "Заголовок" при редактировании первого сообщения темы. И добавленные курсивом эти же самые подзаголовки тоже портятся при пересохранении первого сообщения - исчезают Enter'ы между ними и текстом, нужно их вручную добавлять. В общем, будьте внимательными при изменении первого сообщения темы.

SKcorp
Advanced Member
Сообщения: 3192
Зарегистрирован: 28.07.2008,13:37
Откуда: Leningrad, USSR

Конкурсы

Вклад в сообщество

Bugreport

Сообщение SKcorp » 20.05.2019,03:30

Вот тут: viewtopic.php?p=154702#p154702
Ссылка должна была вести куда-то сюда: viewtopic.php?p=154634#p154634

А ведет в начало темы.

Аватара пользователя
Serge
Тех.адм.
Сообщения: 2026
Зарегистрирован: 04.11.2001,19:04
Откуда: Tallinn, Estonia
Контактная информация:

Bugreport

Сообщение Serge » 20.05.2019,13:10

SKcorp писал(а):
20.05.2019,03:30
Ссылка должна была вести куда-то сюда
Поправил, спасибо.
С наилучшими,
Серж

Музей, оф.сайт

Аватара пользователя
alecv
Advanced Member
Сообщения: 5955
Зарегистрирован: 05.10.2004,11:13
Откуда: Санкт-Петербург
Контактная информация:

Вклад в сообщество

Bugreport

Сообщение alecv » 22.05.2019,15:21

ВЛОЖЕНИЯ
[Расширение arj было запрещено, вложение больше недоступно.]
Что не так c arj ?

Аватара пользователя
uav1606
Advanced Member
Сообщения: 4652
Зарегистрирован: 16.01.2008,22:04
Откуда: Енакиево
Контактная информация:

Вклад в сообщество

Bugreport

Сообщение uav1606 » 22.05.2019,15:30

Добавил в список разрешённых. Видимо, разработчики phpBB про этот тип архивов и не слышали. :-)

abomin
Advanced Member
Сообщения: 457
Зарегистрирован: 17.02.2016,06:52
Откуда: Новомосковск

Bugreport

Сообщение abomin » 23.05.2019,11:06

"Серебряная" [дискета] пишется с одной "н".
_______________________
1000 bits are enough for me

Ответить